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SIM808 GSM GPRS GPS Dev Board IPX SMA with
GPS Antenna for Arduino Raspberry Pi

Introduction:

SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS Antenna is a complete Quad-
Band GSM/GPRS module, which combines GPS technology for satellite navigation. The
compact design, which integrated GPRS and GPS in a SMT package, will significantly save time
and make it easier for users to develop GPS enabled applications. Featuring an industry-standard
interface and GPS function, it allows variable assets to be tracked at any location and anytime

with signal coverage. The module can also be controlled via AT commands.
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Specifications:

5-18V power supply supported.

USB port can be very convenient.

Serial USB TTL compatible for 2.85V, 3.3V and 5v signal.

GSM, GPRS, GPS {text messaging, data transmission, positioning} triple function.
Quad-band communications, globally available. , AT command operation, can support
SMS, phone, GPRS data, GPS data is automatically output, embedded TCP protocol to
support transparent mode and command mode, supports HTTP protocol to support
DTMF decoding, support MMS, support recording function, and so on.

IPX antenna connector.

Reserved USB port (not solder) available for changing firmware. So you can update for
Bluetooth.

Quad-band 850/900/1800/1900MHz.

GPRS multi-slot class 10 standard.

GPRS mobile station class B standard.

Meet the GSM phase 2/2 + standards:-

Class 4 (2 W @ 850/900 MHz).

Class 1 (1 W @ 1800/1900MHz).

AT command control (GSM 07.07, 07.05 and SIMCom enhanced AT command set).
SIM Application Toolkit.

Supply voltage range:

GPRS:3.2~48V.

GPS: 3.0 ~4.5V.

Low power consumption.

Size: 30 * 30 * 3.2mm.

Weight: SIM908: 5.2g.

Working temperature: -40 ° Cto +85 ° C.

SMS.

Point MO and MT.

SMS Cell Broadcast.

Text and PDU mode.

\Voice, Three kinds of rate.
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e Support echo suppression algorithm.

e GPRS data.

e GPRS class 8/10: Maximum 85.6 kbps (downlink rate).

e Support PBCCH.

e Coding schemes CS 1, 2, 3, 4.

e PPP-stack.

e CSD data.

e CSD up to 14.4 kbps.
e USSD.

e Nontransparent.

e Compatibility: AT cellular command interface.

e GPS Receive Type
Receive 42 channels
GPS L1 C/ A code,

High-performance STE engine.

e Sensitivity.
Tracking: -160 dBm.
Cold starts: -143 dBm.
e Time-To-First-Fix.
Cold start: 30s (typ.)
Hot start: 1s (typ.)

e Accuracy.

Accurate positioning: <2.5 m CEP.

e Power consumption (GSM idle mode).

Capture 77mA.
Tracking 76mA.
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Applications:

e Tracker device.

e Controlling or data gathering device via text messages.

Objectives:

This tutorial will shows you a few simple steps about how to use SIM808 GSM GPRS GPS Dev
Board IPX SMA with GPS Antenna by using Arduino Uno. At the end of this tutorial, you will

get a result of comparison when the module can detect its location via satellite GPS coordinate.

Components needed:

Arduino Uno and USB Cable.

Jumper wires.

SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS Antenna.

2V 1A Power Adapter.

Procedures:
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SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS Antenna Schematic
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Step 1: Inserting SIM card & wiring connection to use only GSM part of the SIM808 GSM
GPRS GPS Dev Board IPX SMA with GPS Antenna.

1. Inserting the SIM card into SIM808.

Slide to left to open & slide to right to

close.

Pull up the SIM holder & then slide in Slide in the SIM card into correct

the SIM card into the holder opening. position.

Push down the holder & then slide it to
Finished inserting the SIM card.

the right to close.
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2. Use jumper wires to connect Arduino Uno to SIM808 like the picture below.

Arduino Uno SIM808
10 TX
11 RX
GND (GROUND) GND (GROUND)

OIGITAL |

o ARDUING &
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Step 2: Installing SIM808 library into Arduino IDE.

1. Restart Arduino IDE after Board installation complete. Download the SIM808 library
(https://github.com/DFRobot/DFRobot_SIM808).
2. Click on Sketch > Include Library > Add .ZIP Library...

& 5|M308_SMS5read | Arduino 1.8.19
File Edit Sketch Tools Help

WVerify/Compile Ctrl+R
Upload Ctrl+L
SIMEDE Upload Using Programmer  Ctrl+Shift+ LU
165 Export compiled Binary Ctrl+Alt+5
Show Sketch Folder Ctrl+ K
f Include Library : &
E_ Add File.. Manage Libraries... Ctrl+Shift+|
7 Add ZIP Library...

3. New windows will pop-up Navigate & Select downloaded SIM808 library earlier.

Downloads
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Step 3: Uploading Program into SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS
Antenna to test GSM function.

1. On Arduino IDE click on File > Examples > DFRobot_SIM808 > SIM808_SMSread.

2. Edit part of the coding to match with the pictures below.

char phone[l&é]:
char datetime[24]:

//#define PIN TX 14

//#define FIN EX 11

ffS5oftwareSerial mySerial (FIN_TE, FIN_EX);

ffDFRobot STM308 3im308 (emySerial) ;//Connect BX,TX, FWER,

DFRobot SIM80E =2im308 (e5erial):
vold setup() {
SimySerial . begin (9600) ;

Serial.begin{9e00);

JUEARERRAY Tpitialize 3imS808 module *¥drdddaibady
while(!sim803.init{}) |

V

char phone[l&]:
char datetime[24]:

#define PIN TX 1a

#define PIN_RX 11

SoftwareSerial mySerial (PIN_TX,PIN RX);

DFRokot 5IMB808 3im808 (cmySerial);//Connect BX,TX,FWR,

volid setup() {
mySerial.begin{9e00);
Serial.begin{9600);

SAvexxrsdd Tpitialize sim808 module *dFdvdwdedwwd

wWhile{'aim2808.inic()) {
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3. Make sure Arduino UNO already connected with PC. Select the right board for Arduino
UNO by navigate to Tools > Board: > Arduino AVR Boards > Arduino Uno.

© 5|M208_SM5Sread | Arduino 1.8.19
File Edit Sketch Tools Help

Auto Format

Archive Sketch
SIMB08_SMSre Fix Encoding & Reload
18 Manage Libraries... Crl+Shift+
- Serial Maonitor Ctrl+5Shift+M
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNIMA Firmware Updater

Board: "Arduino Uno" H Boards Manager...
Port . Arduino AVR. Boards ¢ Arduine Yan
Get Board Info ESP8266 Boards (3.0.2) ° ®  Arduino Uno
12 Programmer: "AVRISP mkll s Arduino Duemilanove or Diecimila

Burn Bootloader Arduino Nano

4. After selecting board, make sure to select the right COM PORT for your Arduino Uno.

5. After selecting PORT, click on UPLOAD to start uploading the code into board. Wait until

done Uploading message appear.

36 Frreueddxkr Tpitialize 3imB08 module *&dFdkkbddddd
37T whils({!sim80&.initc{)) [
: Serial.vprint{"5im808 init error\rin™i:

36 SUunwkkkwy Tpitialize 3imS08 module SXFFEENNLLLNN
37E  while(!sim808.init{)) {

Serial.print{"5im808 init error\r\n™i:
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36 fekkxkddd Initialize 3imB08 module ddddekrkaas
E'EI \.hll {(!'sim808.inic(})) [
38 Serial.printi"5im808 init errorir\n™i:

6. Powered on your Arduino Uno & SIM808 and then press the start button on your SIM808 to
start.

7. Observe the D3 Led. When successfully contact to service provider the LED will blink. It
takes 3 seconds for each blink to occur, less than that means it still not able to contact service
provider. (Side note: Sometime it take a while to contact service provider. Depends on the
SIM card service provider signal strength).

It take 3
seconds
for each
blink to
light up.

8. Open serial monitor in Arduino IDE and select 9600 baud and wait for the output to appear
like the picture below.
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nqInit Success, please send SMS message to me!
messagelndex: 0O
messagelndex: 0O

9. Open a smartphone and then send a simple message to the SIM card numbers used.
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Step 4: Uploading Program into SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS
Antenna to test Bluetooth function.

1. To test Bluetooth function, we will use the same exact circuit but with different coding.

2. Go to this link https://acoptex.com/uploads/ATcomands_setupmodule.ino and copy the
coding.

sims 2 Complete Sounct 5 . 5100 series Bluetooth AT

&« &) O 8 acoptex.com

) Getting Started € v2 vz B sH @16 @17z @ Niagawan @ NetPay LG Cytron [l 5

;t
Project: SIMB@8 GSM GPRS GPS Bluetooth evolution board (EVB-V3.2)

Function: Serial communication with evelution board

RX is digital pin 2 of Arduinc board (connect to TXD of EVB-V3.2
TX is digital pin 3 of Arduino board (connect to RXD of EVB-V3.:
* f

f
;;tttttttXttttttXtttttttttttXttttttttttttttttt
#include <SoftwareSerial.h>//include library code
;;tttttttXttttttXtttttttttttXttttttttttttttttt
SoftwareSerial GPSmodule(2, 3);//RX, TX
;;*tttt**ttttt**ttti**tttt**tttt**ttti**tttt**tt

void setup()
r

1

GPSmodule.begin(966@) ;
Serial.begin(960@);

Serial.print("Please enter AT command:™);
delay(1ee);

void loop()
I

1

if (Serial.available():@)
GPsmodule.write(Serial.read());
if (GPSmodule.available():»8)
Serial.write(GPSmodule.read());

}

3. Create a new sketch on Arduino IDE and paste the coding into it.

@ cketch_aprifa | Arduino 1.8.19
File Edit Sketch Tools Help

sketch_apriga §
15

IFEE RS SRR R R
$include <SoftwareSerial.h>//include library code
IFEE RS SRR R R

SoftwareSerial GPSmodule {2, 3);//R¥, TX
;;llll11111111llllllllllllllllllllllllllllllllll

13 |void setup()

14E {

15  GPSmodule.begin(9600);
16 |Serial.l goay

1 Serial.pr "Please enter AT command:™);
delay(100);

19 |}

20 |woid loop()

218 []

2 if (Serial.availakle()>0)

23 GPSmodule.write (Serial.r=ad{));:

4 if (GPSmodule.availakle () >0)
Serial.write (GPSmodule.r=ad{)):

26
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4. Edit a line of the code to be the same as the highlight line of code in the picture below.
@ sketch_apriga | Arduino 1.8.19
File Edit Sketch Tools Help

sketch_apriBa §
18

ME L Ok

Frokkkhhkhbhkhhbhkh bk bk bbb bbbk bbbk bbbk bbb b kbbb bbbk
8 #include <SoftwareSerial.h>//include library code
__.'__.'AAAAA.AAAAAAAAAA.AAAAAAA.AAA.AAAAAAA.AAA.AAAAAAA.AA
11 SoftwareSerial GPSmodule(10, 11)://TX, R}d

12 R R R R R R RS R R R RS R R R

13 |woid setup()
14B/{
15 GPSmodule.besgin(9600);
16 Serial.begin(%600);
1 Serial.print ("Please enter AT command:™);
12 delay(l00);
g |1
void loop()
=0

if (Serial.availakls()>0)
GPSmodule.write {Serial.read());
if (GPSmodule.available {)>0)
Serial.write (GPSmodule.r=ad{));

W= L bO

[ S N R

5. When you finish edit the code, upload the new coding into your Arduino Uno.

6. Take out your smartphone and turn on the Bluetooth.

7. Open your app store in your smartphone to download and install this Valtrack app:
https://play.google.com/store/apps/details?i

2

d=com.valetron.valtrack

C

&hl=en&gl=US.

$: 10

Valtrack-V2 Setup

Not Connected
VALTRACK-V2
Setup Band: | Select Network Band Send
WMode:| SMS v |'Send
Alert: | NONE v | Send
Motion:| Enter Motion Threshold Send
What's new - = =
Contact| Enter Contact Number Send
APN: | Enter APN Name Send
. Name: | Enter APN User name Send
Rate this app —
Passwd: Enter APN Password Send
H-URL: |Enter HTTP URL Send
H-Key: |Enter HTTP Key Send
Interval | Enter Ping Interval Send
Developer contact
M-Host:| Enter MQTT Host address Send
About this app M-Port:| Enter MQTT Port Send
M-CID: | Enter MQTT Client ID Send
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7. Keep the Valtrack app open on your smartphone.

8. Power on your SIM808 and press the start button again to start.

9. Open serial monitor and set it on 9600-baud frequency.

10. Use this step-by-step table AT commands below to set up and test the SIM808 Bluetooth
function. (Side note; Use the link provided below for more SIM808 Bluetooth AT commands).
https://cdn-shop.adafruit.com/product-

files/2637/S1IM800+Series Bluetooth Application Note V1.04.pdf

AT+BTSTATUS?

To check the Bluetooth

status. 0 means that the

Bluetooth is turn OFF in
SIM808.

o COMG
|

Please enter AT command:AT+BTSTATUS?
+BTSTATUS: O

OK

AT+BTPOWER=1

To power on Bluetooth in
SIM808. Parameter 1
means ON 0 means OFF

AT+BTEPOWER=1
OK

AT+BTSTATUS?

To check the Bluetooth
status again. 5 means that
it is power on and in idle.

AT+BTSTATUS?
+BTSTATUS: 5

OK

AT+BTSCAN=1,10

To scan for any near
Bluetooth device
available. Parameter for 1
means start and 10 means
how many second you
want to take to search for
a device.

AT+BTSCAN=1, 10
OK

+BTSCAN: 0,1, Bezz Bealme 5i",d0:28:ba:@e:08:22,-T4

+BTSCAN: 1

AT+BTPAIR=0,1

To pair with my
smartphone with a device
IDof 0,1

AT+BTPAIR=0,1
OK
L]

+BTPAIRING: "Eezz Bealms 5i",d0:28:ba:ee:08:22,042811
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Your smartphone will
pop up this message
asking permission to be
pair with

SIMCOM/SIMB808. Click

pair.

Bluetooth pairing

Pair with device "SIMCOM"?
Make sure the pairing code displayed on
that device is: 589750.

AT+BTPAIR=11

To accept the pairing
request sent by the
smartphone. Parameter
1,1 is to accept pair with
my smartphone device
ID.

AT+BTFAIR=1,1
0K

+BTEATR: 1,"RBezz Bealms 5i",d0:28:ba:ee:08:22

AT+BTSTATUS?

To check the Bluetooth

status again. The output

show that it already pair
with my smartphone.

AT+BTSTRTUS?
+BTSTATUS: 5
P: 1,"Rezz Bealme 5i",d0:28:ba:ee:08:22

OK

AT+BTGETPROF=1

To find what profile ID
supported. Parameter 1 is
my device given ID.

LAT+BTGETPROF=1

+BTGETEPROF: 4,"SEE"
+BTGETPROF: 3, "AVRCE (Target)"
+BTGETEROF: 10, "PELP"
+BTGETPROF: 2, "HFP(LAG)"

AT+BTCONNECT=1,4

To connect using SPP
profile label 4.

AT+BTCONNECT=1,4
OK

+BTCONNECT: 1, "Bezz Realme 5i",d0:28:ba:ee:08:22, "SPP"

Valtrack app on your

smartphone will show

that it is connected to
SIMCOM/SIM808

3200 @ BIDOW T 37 e E @ . LR RORS RN )

Valtrack-V2 Setup

Valtrack-V2 Setup

Not Connected Connected:SIMCOM
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Use APN box to send a
short message to SIM808

Band : Select Network Band . Send
WMode:| SMS v | Send
Alert: | NONE v | Send
Motion ;| Enter Motion Threshold ’ Send
Contact| Enter Contact Number y Send
APN : [tim ] Send
Name: ‘ Enter APN User name ’ Send
Passwd:‘ Enter APN Password ’ Send

The sent message will
appear in serial monitor
shortly after.

AT+BTSPPSEND=10

To send message from
SIM808 to your

+BTCONNECT: 1,"Bezz Realme 5i™,d0:28:ba:ce:08:22, "SPE"

+BTSPPDATA: 1,18, VALETRON:S-Hello#

smartphone. Parameter | HELLOZU2%] |
10 is the length of text il
AT+BTSPPSEND=10
Remember to put a > N 2 #
hashtag (#) at the end of SEND OH
the message to end the
sentence to send.

Contact| Enter Contact Number ’ Send
APN : [‘Enter APN Name I Send
Name: [Enter APN User name J Send
SIMCOM: HELLO_2U2#

The sent message will
appear in Valtrack app
shortly after.

B & - ¢

° () ©IF

I 28 1S 143 £ B0 A8 FS ROl 1D

@ # $ _ & - +

=\< * n 1

ABC
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AT=BTUNPAIR=1

To un pair
SIMCOMY/SIM808 from
your smartphone.
Parameter 1 is your
device ID.

|

AT+BTUNFAIE=1
OK
AT+BTSTATUS?
+BISTATUS: 5

OK

Step 5: Uploading program into SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS

Antenna to test GPRS GPS function.

1. To test Bluetooth function, we will use the same exact circuit but with different coding and
also attaching the GPS/BD Antenna to SIM808.

1e1:GPS/BD

2. On Arduino IDE click on File > Examples > DFRobot_SIM808 > SIM808_GetGPS.

3. Edit part of the coding to match with the pictures below.

17 #include <DFRobot SIMBOS.h>
15 #include <SoftwareSerial.h>

17 #include <DFRobot SIMBOE.h>
1%  g#include <SoftwareSerial.h>

//#define PIN_TX 10
f//#define PIN RX 11
f{SoftwareSerial mySerial (FIN_TX, FIN_EX);

DFRobot STMB0E sim308({sSerial);

//DFRobot_SIM208 s3im808 (smySerial);//Connect RX,TX, FWR

14

20 gdefine PIN_TIX 1a

21 #define PIN_EX 11

22 SoftwareSerial mySerial (PIN_TX, PIN_BRX);

23 DFRobot SIMBOS sim808 (smySerial)://Connect RX, TX,PWR,
24

25

7E ygd =tun () |
8 JimySerial.bkegin (%600} I
g SETiSl.Cogin(0800) §

[ S S R A S ]
@ tn )

320  while(!sim308.inic{)) {

31 fUeexxxxax Tnitialize 3im303 module *Fddradadiaas

2éB void setup() |
7 mySerial.kbegin{9600);
Serial.begin(9600);
30 Jrukkkkxx% Tpitialize simB08 module *4&EEEEEERALX

31H  while(!sim808.init()} {

H
<
[T !y
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4. Upload the coding into your Arduino Uno.

5. When done uploading the code, power ON your SIM808 and then press the start button.

6. Open up your serial monitor in Arduino IDE and set it to 9600 baud.

7. It takes a few minutes to get the coordinates but it should output like in the picture below.

o TS

5im308 init error

5im308 init error

5im208 init error

S5im208 init error

S5im208 init error

Open the GPS power success
202274721 5:27:2:9
latitude :5.2843E81
latitude :5~17'3.771288"
longitude :100.454041
longitude :100+29%38.5459194"
speed _kph :0.58

heading :206.42

28 1 a4 £

Conclusion:

SIM808 GSM GPRS GPS Dev Board IPX SMA with GPS Antenna, can connect using GSM
to mobile service provider to send/receive SMS message and also GPRS GPS function that can
be locate to it exact coordinate receiving signal using GPS/BD antenna from satellite.
Furthermore, SIM808 can also be connected via Bluetooth to any device that support it to relay
any data/information from SIM808 to a third party device for example like a smartphone. To
test all this feature is pretty simple just by using the examples from SIM808 library installed in

Arduino IDE to test each features separately.
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