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ESP8266 ESP-01 10A 250AC Relay module

Introduction:
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ESP8266 ESP-01 10A 250AC Relay module is a smart relay module based on the ESP-
01S WIFI module design. It can be used to ‘do it yourself” (DIY) your own smart switch. This
relay module is designed to be controlled with low voltages like 3.3V like ESP8266 ESP-01,
ESP-01S, etc., or 5V like your Arduino. It can be remotely controlled by the mobile phone APP
and provides APP and LUA source programs. It is easy to implement into projects and quite

convenient to use.

For purchase & enquiries, please contact sales @synacorp.com.my or call 04-5860026



mailto:sales@synacorp.com.my

SYNACORP TECHNOLOGIES SON. BHD. (1310487-K)
AgYN No.25 Lorong |/SS3. Bandar Tasek Mutiara.
14120 Simpang Ampat. Penang. Malaysia.
&_,> ACORP T: +604.586.0026 F: +604.586.0026

Your Strategic Solutions Provider WWW.Synacorp.my | Email- sales@synacnr‘p.cum.my

Features:

e Module working voltage: DC 5V

e Relay load capacity: 10A 250VAC 10A 125VAC 10A 30VvDC 10A 28VvDC

e Designed for ESP01 - ESP8266 module, supporting both ESP-01S and ESP-01
e Built-in Single Pole Double Throw Relay supporting 250AC, max 10A

e Relay outputs: NC, NO and COM are extended out to screw terminals

Applications:

e Smart switch.

e Remote wireless switch control.

Objectives:

This tutorial will shows you a few simple steps about how to use ESP8266 ESP-01 10A 250AC
Relay module by using ESP8266 ESP-01S. At the end of this tutorial, you will get a result of
comparison when the relay module can turn on and off via wireless control using smart phone

app Blynk.

Components needed:

e Jumper wires.

e Breadboard.

e UART/TTL Serial Programmer (FT232RL FTDI).
e ESP8266 ESP-01S Wi-Fi Serial Transceiver Module.
e ESP8266 ESP-01 10A 250AC Relay module.

e Push button (Optional)
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Procedures:

Step 1: Wiring connection to program ESP8266 Wi-Fi Serial Transceiver Module.

1. We need to connect ESP8266 ESP-01S Wi-Fi Serial Transceiver Module to ESP01/01S Relay
Module so that we can control the relay via Wi-Fi. To program ESP8266 ESP-01S, UART / TTL
Serial Programmer is required to be connected with ESP8266 ESP-01S and a PC with Arduino IDE
software installed. The connection between ESP8266 ESP-01S and UART / TTL Serial

Programmer, is shown as diagram listed below:

ESP-01S ESP8266 FT232RL FTDI
VCC VCC
GND GND
X RX
RX X
CH _PD/EN VCC
GPIO 0 GND
GPIO_2 -
5.GPIO -0
7.Rx
8. VCC (+3.3V)
pe——6. Reset
et ] CH_EN
pre—p-2 . T
1. Ground

3.GPIO -2
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Step 2: Installing ESP8266 Board into Arduino IDE

1. Open Arduino IDE Preferences setting by clicking on File > Preferences.

Preferences
Settings  MNetwork

Sketchbook location:

C:\Wsers\Admin\DocumentsArduino

Editor language: System Default

Editor font size: 12

-

Interface scale:
Theme:
Show verbose output during: [_| compilation [_] upload

Compiler warnings: MNone -~

Display line numbers

Verify code after upload
Check for updates on startup
[] Use accessibility features

Mare preferences can be edited directly in the file
C:\Wsers\Admin\AppData\Local\Wrduino 15\preferences. txt

(edit only when Arduine is not running)

Browse

~ | (requires restart of Arduino)

[+] Automatic | 100 7 % (requires restart of Arduino)

Default theme - ({requires restart of Arduino)

[[] Enable Code Folding
[] Use external editor

Save when verifying or uploading

Additional Boards Manager URLs: | http: /farduino.esps266. com/stable fpackage_esp@266com_index. json ﬁ

oK Cancel
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2. Add http://arduino.esp8266.com/stable/package _esp8266com_index.json into Additional
Boards Manager URLSs: and click on OK.

3. Open Board manager by clicking on Tools > Board: > Boards Manager... Search for
ESP8266 and click on ADD / INSTALL. Wait until installation complete (Require Internet

Connection).

& Boards Manager

Type |All « | |espa26g

espB266

by ESP8266 Community version 2.7.2 INSTALLED

Boards included in this package:

Ganeric ESPE266 Module, Generic ESP8285 Module, ESPDuino (ESP-12 Madule), Adafruit Feather HUZZAH ESPE266, Invent One,
XinaBox CWO01, ESPresso Lite 1.0, ESPresso Lite 2.0, Phoenix 1.0, Phosnix 2.0, NodaMCU 0.9 (ESP-12 Modula), NodeMCU 1.0
(ESP-12E Module). Olimax MOD-WIFI-ESP8266(-DEV), SparkFun ESP8266 Thing, SparkFun ESP8266 Thing Dev, SparkFun Blynk
Board, SweetPea ESP-210, LOLIN{WEMOS) D1 R2 & mini, LOLIN(WEMOS) D1 mini Pro, LOLIN{WEMOS) D1 mini Lite, WeMos D1
R1, ESPino (ESP-12 Module). ThaiEasyElec's ESPino, Wiflnfo, Arduino, 4D Systems gen4 IoD Range, Digistump Oak, WiFiduino,
Amperka WiFi Slot, Seeed Wio Link, ESPectro Core, Schirmilabs Eduine WiFi, ITEAD Sonoff, DOIT ESP-Mx DevKit (ESPE285].

Cnline Help
More Info

Select version .- Install Remove

Close

Step 3: Installing Blynk Library into Arduino IDE

1. Restart Arduino IDE after Board installation complete. Download the Blynk library
(https://github.com/blynkkk/blynk-library/releases/download/v0.6.1/Blynk_Release v0.6.1.zip).

2. Click on Sketch > Include Library > Add .ZIP Library...

@ BLYNK_8266 | Arduino 1.8.13 — O %

File Edit Sketch Tools Help

Verify/Compile Ctrl+R
Upload Ctrl+U
BLYMNK Upload Using Programmer  Ctrl+Shift+U
1 #dez Export compiled Binary Ctrl+Alt+5
2 #ing il
3 #ing Show Sketch Folder Ctrl+ K Manage Libraries... Ctrl+Shift+|
4 #ing = 3
" Include Lib :
- nefude Loy Add ZIP Library...
¢ chad Add File...
7 char ssid[] = "POCOPHONE F1"; // Synacorp Arduina libraries
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3. New windows will pop-up Navigate & Select downloaded Blynk library earlier.

@ Select a zip file or a folder containing the library you'd like to add X
Lookin: | < Downloads v ¥ eeE-
n Apps Notes
1 Fritzing
=
Recent Items Installer
LiB
PIC
| Relay
Desktop Telegram Desktop
1w B nk_Release_v(.6.1.zip
A=)
E
Documents
This PC
Network
File name: Blynk_Release_v0.6.1.zip
Files of type: | ZIP files or folders v Cancel

Step 4: Getting Blynk App ready

1. Download Blynk app from Gooale Play Store or Apple App store.

2. Once downloaded launch the app & create or sign-in if already have an account.

3. Tap on New Project, enter project name (Example: ESP-01S), select ESP8266 as device and Wi-Fi

as connection type. Tap on create and the app will send Auth Token to registered e-mail.
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ESP-01S

ESP8266

New Project

O

=Y

Auth Token was sent to:
imran.afig98@gmail.com

Don't show again

22

Community

Auth Token for ESP-01S project and device ESP-01S X x &

Blynk ¢ A -

4. Once Auth Token received Tap on Plus (+) icon to add features that called Widget Box. Tap on
Button configure as pictures shown below. Create two buttons. Make sure the WIFI LED button
OUTPUT is configured as GP2 1 — 0 and select MODE as SWITCH. For the RELAY button set
the OUTPUT as GPO 1 — 0 and select MODE as SWITCH as well.
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Button
Styled Button WIFI LED
Slider
Vertical Slider
a Timer
Joystick
< zeRGBa
StepH

Step V

RELAY SWITCH

5. Once finished go Back and Tap on Play button (on Top Right Corner of app) to start.
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6. Blynk will show error message on Board icon (Top Right Corner). The error message was
“ESP-01S Wasn’t online yet”. Ignore this for while because the program still not uploaded into
board.

Step 5: Uploading Program into ESP8266
1. On Arduino IDE click on File > Examples > Blynk > Board_WiFi > ESP8266_Standalone.
2. Fill in Wi-Fi ID (Name), Wi-Fi Password & Blynk Auth Token keys (Received via e-mail on

previous step). (Side note; make sure the Wi-Fi use for the coding is 2.4G and not 5G becauseit

support 2.4G bandwidth only).

#define BLYNE PRINT Serial #define BLYNEK FRINT Serial
ginclude <ESP8266WiFi.h> #includes <ESPE266WiFi.h>
#include <BlynkSimpleEspS266.h> g¢include <BlynkSimpleEsp8266.h>

ff You should get Ruth Token in the Blynk App.

ff Go to the Project Settings ({nut icon).
char auth[] = "YcurAutthkenr:

f4 Your WiFi credentials.

/¢ Set password to "" for open networks.
char 3sid[] = "YourNetworkName"™:

char pass[] = "YourPassword"™;

void setup()

{
f/ Debug console
Serial.begin (9600);
Blynk.b=egin{auth, ssid, pass);

}

void loop()
{

Blynk.run():
}

H1

/4 You should get AZuth Token in the Blynk App.
/S Go to the Project Settings (nut icon).
char auth[] =

/4 Your WiFi credentials.

/¢ Set password to "™ for open networks.
char ssid[] = "POCOPHONE F1™:

char pass[] = "imranafig93";

void setup()

{
/4 Debug conscle
Serial.begin (9600} ;

Blynk.k=gin{auth, ssid, pass);
}

void loop()
{
Blynk.run();
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3. Make sure programmer already connected with PC. Select the right board for ESP-01S by
navigate to Tools > Board: > ESP8266 Boards (2.7.2) > Generic ESP8266 Module.

dalone | Arduino 1.8.13 == O X
Tools Help
Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload
Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "Generic ESP8266 Module" Boards Manager...
Builtin Led: "2" Arduino AVR Boards
Upload Speed: "115200" ?‘ ESP32 Arduino

CPU Frequency: "80 MHz" " ESP8266 Boards (2.7.2) *
Crystal Frequency: "26 MHz" 5—

ﬂ
Generic ESP8266 Module
Generic ESP8285 Module
ESPDuino (ESP-13 Module)
Adafruit Feather HUZZAH ESP8266
Invent One
XinaBox CWO1
ESPresso Lite 1.0
ESPresso Lite 2.0
Phoenix 1.0
Phoenix 2.0

4. After selecting board make sure all the configurations are same as picture below. Select the

right COM PORT that your FT232RL FTDI registered to.

WiFi101 / WiFiNINA Firmware Updater

Upload Speed: “115200"

CPU Frequency: "80 MHz"

Crystal Frequency: "26 MHz"

Flash Size: "1MB (FS:64KB OTA:~470KB)"
Flash Mode: "DIO"

Flash Frequency: "40MHz"

Reset Method: "no dtr (aka ck)"

Debug port: "Disabled”

Debug Level: "“None"

IwlP Variant: "v2 Lower Memory"
VTables: “Flash"

Exceptions: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

Port
Get Board Info

Halone | Arduino 1.8.13 - O X
[Tools Help
Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload
Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

ﬁard: “Generic ESP8266 Module" \
Builtin Led: "2"

Espressif FW: "nonos-sdk 2.2.1+100 (190703)"
SSL Support: "All SSL ciphers (most compatible)’,
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Make sure these important configurations are same

Board: “Generic ESp8266 Module”
Upload Speed: “115200”

Flash Size: “IMB (FS:64KB OTA:
~470KB)”

Flash Mode: “DIO”

Reset Method: “no dtr (aka ck)”

5. After finish selecting PORT, click on UPLOAD to start uploading the code into board. Wait
until Done Uploading message appear.

@ ESPB266_Standalone | Arduine 1.8.13 - O x

File Edit Sketch Tools Help

ESPA266_Stan

#di

e <E5PE266WiFi.h>
= <BlynkSimpleEsp3266.hx

u should get Ruth Token in the Blynk App.
the ct Settings (nut icon)
nrgMdcsipnll6KGh4k GWIVWCFhZIYEL4™;

Tour WiFi credentials.

t password to "" for open networks.
33id[] "POCOPHONE F1™;

ar pass[] "imranafig93";

43 |woid SECJIZ?
ralr

< >

dule on COME
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Step 6: Wiring Connection — Testing

|| ||
A |
® ¢ 8 8 s s s 0 s e s e e ..
® s 8 8 0 0 0 0 s e s e e e LI
LRI R R I B I I R I B * e e
® s e 0 s e e e e e e e ..
® ¢ 88 s s s 0 s s s s e LI
® ¢ e 0 e e e e s e e e . o o
® ¢ s s s s s 08 s s e L
D ¢ ¢ o s s 0 0 s s s s e e
IENEEED ¢ & & & & & 8 & & 6 8 6 8 8 N e e
I------------------_-

Disconnect GP10-0 from GND and Connect Reset to GND via Push Button Switch.

1. Connect the ESP-01S based on picture above.
2. Open Serial Monitor tab (CTRL+SHIFT+M) on Arduino IDE.

@ ESP8266_Standalone | Arduino 1.8.13

File Edit Sketch Tools Help

ESP8266_Standalone §

ple. code is in public doma

[ Autoscroll Show timestamp |Noline ending | |9600 baud v Clear output
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3. Click the Push button once to reset the ESP-01S. This step is to force ESP-01S reset and run /

load the program recently uploaded to the board. Once board reset serial monitor will display ESP-
01S attempt to connect Wi-Fi.

@ come — O *
| Send
17:34:45.308% -» OVO%8%%[85] Connecting to BOCOPHONE F1

17:34:51.911 -»> [2589] Connected to WiFi

17:34:51.4957 -» [2589] IP: 192.1658.43.4%

17:34:51.4957 -» [2589]

17:34:51.957 -> L o

17:34:52.004 ->» Fo_0 ff_

17:34:52.052 ->» fF_ AN S

17:34:52.082 -> /__ [ /N_, A_07_F_IN N\

17:34:52.098 -> f___/ v0.6.1 on ESPB266

17:34:52.098 ->

17:34:52.098 -> [2666] Connecting to blynk-cloud.com:30

17:34:52.191 -> [2824] BReady (ping: 20ms).

[ Autoscroll [] Show timestamp Mo line ending | | 9600 baud ~ Clear output

4. Once Blynk app Tap on Wi-Fi LED button that created in Step D-4 to turn ON/OFF LED
onboard indicator. Blynk app will show the board is online when connected to Wi-Fi (make sure
Wi-Fi got active 2.4G internet connection).

) ESP-01S

Online since 04:17 PM Apr 6, 2022
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Step 7: Connecting ESP-01S ESP8266 to ESP8266 ESP-01 10A 250AC Relay module.

1. Unplug all the wires from ESP8266 ESP-01S.

2. Connect ESP8266 ESP-01S to the relay module by inserting the eight pins of ESP8266 ESP-

01S into the relay module eight pins socket like the pictures below.

Step 8: Wiring connection & testing ESP8266 ESP-01 10A 250AC Relay module to an LED circuit.

1. Create a simple LED circuit and use the relay module as a switch for the LED as shown in the

pictures below.

[ O-1S-D0AL0-QYS ~
| 20A8Z YOI J0AOE YOI
JVASZI YOI JVAOSZ YOI

b A AT

zzsszs]::‘;erszsss N0 Nommally Open
COM Common
NC Normally Close
GND Ground
VCC | Voltage at the Common Collector

[ e 5

+
ACORDCPOWER DC5V-12V
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2. Powered on the circuit and relay module.

3. Open your Blynk app on your phone and turn ON and OFF your WIFI LED and
RELAY SWITCH buttons to see the results as below.

WIFI LED: OFF RELAY SWITCH:OFF WIFI LED: ON RELAY SWITCH:OFF

WIFI LED: ON RELAY SWITCH:OFF WIFI LED: ON RELAY SWITCH:ON
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Conclusion:

ESP 8266 ESP-01S need to be connect to relay module so a user can access it via Wi-Fi to turn
it ON and OFF wirelessly. Before that, ESP 8266 ESP-01S need to be code with a simple Blynk
coding to connect it with the Blynk app. After that, to program the ESP 8266 ESP-01S, USB to
UART FTDI Converter is required to connect ESP 8266 ESP-01S to a PC. Then, upload the
Blynk code provided via Arduino IDE to ESP8266 ESP-01S. Afterward, remove the connection
between the ESP 8266 ESP-01S & UART / TTL Serial Programmer. Lastly, connect the ESP
8266 ESP-01S to the ESP8266 ESP-01 10A 250AC Relay module and powered it on so that
you can test it when you open the Ul in the Blynk app that already been set up.
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