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Using Compatible Arduino Uno R3 and Nano ATmega328PB model
IC with Arduino IDE

Introduction:

Due to Arduino's open-source nature, many companies and individuals have created
their own compatible boards. These boards often offer additional features or performance
improvements while maintaining compatibility with the Arduino IDE.

Some popular Arduino board examples include:

e Arduino Uno Rev3 e Arduino Nano e Arduino Mega

A). USB Driver Issues

The compatible Arduino models might use slightly different components to cut the
product cost. Most manufacturers use the 3™ party USB to serial chip. This different chip
requires different drivers to work. OS like Windows 10 and 11 will automatically install the
driver once connected to the internet through Windows Update. Official Arduino Uno and
Mega boards use the Atmel ATmegal6U2 chip, and the driver usually get installed
automatically with the Arduino IDE.

Mostly used USB to Serial chip and driver:

e ATmegal6U2 (Atmel) - https://www.arduino.cc/en/software (Driver comes with IDE)

e CH340 Series (WCH) - https://www.wch-ic.com/downloads/CH341SER ZIP.htm|

e CP2102 (Silicon Labs) - https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers
e FT232RL (FTDI Chip) - https://ftdichip.com/drivers/vcp-drivers/

e (CH9102 (WCH) - https://www.wch-ic.com/downloads/CH343SER ZIP.html
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B). Type of IC model

Official Arduino Uno Rev3 and SMD edition MCU boards launch with ATmega328P,
this IC commonly comes in DIP-28P3 and SMD-32A package. Some Arduino Uno and Nano
compatible boards use the newer IC model such as ATmega328PB in SMD package.

This IC is not a drop-in replacement for ATmega328P, but a newer device. However,
the functions are backward compatible with the existing ATmega328 series functions
according to Atmel. This newer model also comes with four additional GPIO’s Pin
functionalities.

C). Bootloader Issues

By using this ATmega328PB IC, user cannot flash the default ATmega328P based on
‘Optiboot’ bootloader. This is because the Signature bytes address ID for both types of
ATmega328’s IC is different; the flashing process will be aborted. The programmer that
Arduino IDE used, which is AVRDUDE will read the Signature byte ID to identify which IC
being programmed or flashed. Since ATmega328PB never intended to being used with the
official Arduino boards, they never released the official bootloader for this IC.

Boards IC Signature bytes address ID
*Standalone IC (no board) ATmega328 O0x1E9514
Official Uno Rev3 & Nano ATmega328P Ox1E950F
Compatible Uno & Nano ATmega328PB Ox1E9516

There are two custom bootloader that can be used with ATmega328PB based IC, the
“ATmega328PB with bootloader” and “MiniCore”. The “ATmega328PB with bootloader”
are based on the official Optiboot bootloader, while the “MiniCore” are based on the newer
Urboot bootloader. Both are tested with Arduino IDE version 1.8.19 (Legacy) and 2.3.2
(New). Before flashing the bootloader, custom board installation thru Arduino IDE must be
done.

Differences

ATmega328PB with bootloader MiniCore
Based on Optiboot Based on Urboot
No extra features (work as standard IC) Unlock few additional IC extra features
Most compatible (direct port) Actively in development
Only for ATmega328PB All ATmega8, 48, 88, 168,328P, 328PB
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D). Flashing Bootloader, requirements

PC (with internet connection to download & install MiniCore)

Arduino Uno / Nano / Mega (any Arduino AVR base board as Programmer)

Arduino Uno / Nano (to be flashed, as a Target comes with ATmega328PB)

Jumper Wires - (via ICSP = Female to Female x 5pcs + Male to Female x 1pcs)
(via Digital + Power Pin = Male to Male x 6pcs only)

P wnNe

E). Installing the Custom Board or Bootloader into Arduino IDE

1. Download and install the Arduino IDE program.
(Arduino IDE v1.8.19 legacy or newer v2.3.2+)

DOWNLOAD OPTIONS
AI’dUInD IDE 1 .8."9 Windows Win 7 and newer
Windows 2IP file
The open-source Arduino Software (IDE) makes it easy to write code Windows app wing.1 or10 | Get -2 |

and upload it to the board. This software can be used with any
Arduino board.

Linux 32 bits
Linux 64 bits
Linux ARM 32 bits

Refer to the Arduino IDE 1.x documentation for installation

. ) i ARM 64 bits
instructions. Linux

Mac OS X 10.10 or newer

SOURCE CODE
Release Notes

Active development of the Arduino software is hosted by GitHub.
See the instructions for building the code. Latest release source AT L)
code archives are available here. The archives are PGP-signed so
they can be verified using this gpg key.

DOWNLOAD OPTIONS
ArdUInO IDE 2.3.2 Windows Win 10 and newer, 64 bits
Windows Msl installer

Windows ziP file
The new major release of the Arduino IDE is faster and even

more powerfull In addition to a more modern editor and a . ) ]
more responsive interface it features autocompletion, code Linux ZIP file 64 bits (X86-64)
navigation, and even a live debugger.

Linux Applmage 64 bits (X86-64)

macOS$S Intel, 10.15: "Catalina” or newer, 64 bits

macOS Apple Silicon, 11: "Big Sur” or newer, 64 bits

For more details, please refer to the Arduino IDE 2.0
documentation. Release Notes

Nightly builds with the latest bugfixes are available through
the section below.

SOURCE CODE

The Arduino IDE 2.0 is open source and its source code is
hosted on GitHub.
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2. Once installed, launch the Arduino IDE. Navigate to toolbar, select File >

Preferences.
& ArduinolSP | Arduine 1.8.19 - O >
File JEdit Sketch Tools Help
W Ctrl+MN
e Ctrl+0
Open Recent ¥
Skechbook b
Exam\ples »08-2011 Randall Bohmn
Clase Ctrl+W v license, see
Save CirleS tce.org/licenses/bsd-license.ph
Save As.. Ctrl+5Shift+5 )
is the Arduino into a AVRISP using
Page Setu Ctrl+Shift+P
Print Ctrl+P to reset the target microcontrolle:
Preferences  Ctrl+Comma §; .. 42y SpT pins MISO, MOSI and !
Quit Ctrl+ 0} Cn all Arduinos, these pins can l
T 77 U = IoJF7 JF L -_"lEEldEI:

3. Once the Preferences tab shows up. Follow the setting from image attached below.

a.

Check the Show verbose output check box on Compilation and Upload. This
option is good for troubleshooting.

Click the icon next to Additional Board Manager URLs, paste the GitHub repo
link and click on OK: -

(i). ATmega328PB with bootloader -

“https://raw.githubusercontent.com/0x6470/ATmega328PB-Arduino-Nano-Clone-

with-Bootloader/master/package m328pb index.json”

or
(ii). MiniCore -

“https://mcudude.github.io/MiniCore/package MCUdude MiniCore index.json”

Display line numbers and Enable Code Folding is optional, but it does help
when the code is too long.
Sketchbook location allows user to change the default compiled code

location. Normally saved in user Document folder.

For purchase & enquiries, please contact sales@synacorp.com.my or call +604-5860026


https://raw.githubusercontent.com/0x6470/ATmega328PB-Arduino-Nano-Clone-with-Bootloader/master/package_m328pb_index.json
https://raw.githubusercontent.com/0x6470/ATmega328PB-Arduino-Nano-Clone-with-Bootloader/master/package_m328pb_index.json
https://mcudude.github.io/MiniCore/package_MCUdude_MiniCore_index.json

SYNACORP TECHNOLOGIES SON. BHD. (1310487-K)

AS\\ No.25 Lorong 1/883, Bandar Tasek Mutiara,
- / 14120 Simpang Ampat. Penang. Malaysia.
) i ACOR P 146045860026 f: +604586.0026

Your Strategic Solutions Provider WEBSITE: www._synacorp.my EMAIL: sales@synacorp.my

Preferences

Settings | Network

Sketchbook location:

C:‘JJsErs‘\TECH\DucumEnis\."-\rduind

Browse
Editor language: System Default ~ | (requires restart of Arduina)
Editor font size: 14
Interface scale: Automatic | 100 5 % (requires restart of Arduing)
Theme: Default theme | (requires restart of Arduina)
IShow wverbose output during: compilation upload I
Compiler warnings: Mone  «
Display line numbers Enable Code Folding
Verify code after upload [ Use external editor
Chedk for updates on startup Save when verifying or uploading
[] Use accessibility features
Additional Boards Manager URLs: |_MCUdude_MiniCore_index.json, https: /fespressif. github. io/arduino-esp32/package_esp32_index.json
More preferences can be edited directly in the file
C:\Uzers\TECH\AppDatalLocal\Arduine 15\preferences, txt
(edit only when Arduino is not running)
Cancel

4 @ Additional Boards Manager URLs

Enter additional URLs, one for each row

https://arduino.esp8266.com/stable/package_espS266com_in .ison
https://espressif.github.io/arduino-esp32/package_esg

index.json

https://adafruit.github.io/arduino-board-inde
https://github.com/earlephilhower/arduino-
https://raw.githubusercontent.com/spar

ackage_adafruit_index.json
Co/releases/download/glokal/package_rp2040_index.json

/Rrduino_Boards/main/IDE_Board Manager/package_sparkfun_index.json

https://raw.githubusercontent.com/0xE6470/ATmega32 8E‘EI*AIduinofNanofClone7wit,thIoot,loader/mastez/package7m32 Spk_index.json

Click for a list of unofficial boards support URLs

oK Cancel

4. Once setting changes have been made, click on OK to close and save the

preferences. It is recommended for users to restart the IDE when modifying the

preferences parameter.

5. Make sure the PCis connected to the Internet. Then, click on the toolbar > Tools >

Boards: > Boards manager...

6. New windows will pop-up (Boards Manager), on the search bar type in “MiniCore”

or “ATmega328PB” and click on Install button. The board will begin download and

get installed automatically.
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&) Boards Manager *
Type Al | |ATmega32s)
ATmega328PB
by Dx6470 version 0.1.0 INSTALLED
Boards included in this package:
ATmega328PB.
More Info
@) Boards Manager X
H Type Al ~ | MiniCore
MiniCore ~
by MCUdude version 2.0.2 INSTALLED
Boards included in this package:
ATmega328/P/PASA/PE, ATmegalss/B/PA/A/PE, ATmegaB8/P/PA/A/PB, ATmega48/P/PA/A/PE, ATmegas.
Cnline Help
More Info
Select version Install Remove
w
Close

7. Once installed, close the Boards Manager window and restart the Arduino IDE. The
MiniCore and ATmega328PB with bootloader option will appear on board selection
menu. Toolbar > Tools > Board: ....

2 ArduinolSP | Arduino 1.8.19 — O

File Edit Sketchi Tools JHelp

Auto Format Ctrl+T
Archive Sketch

Arduinol 3P Fix Encoding & Reload
154 #defin Manage Libraries.., Ctrl+5Shift+]
155 |#defin Serial Monitor Ctrl+Shift+ M
15e #defin Serial Plotter Ctrl+Shift+L
157 #defin
158 ! LWiFi‘lm / WiFiMINA Firrmware Updater
154 oid
- vold ps Board: "Arduino Uno" # Boards MEHEQEF.--
el
161 #ifdef Port Adafruit Boards »
162 #inclu Get Board Info Arduino AVR Boards  *
o e ¥
le3 #else Programmer. "AVR ISP" ATmega32iPs
— i 5
-0 Burn Bootloader ESP32 Arduine
165 #defint—rrmoomo o= ESP8266 Boards (3.1.2) *
lée MiniCore
167 #if !defined (ARDUINC API VERSICN) || RRDUINO AE SparkFun AVR Boards
Cl0 mloos 2DTSOd+imoes 3
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F). Wiring setup
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Flashing bootloader requires 2 Arduino AVR board or AVR Programmer.

1. Upload the ArduinolSP code to the ‘Programmer’ Arduino. Navigate to the Toolbar >
File > Examples > 11. ArduinolSP > ArduinolSP.

2.

) ArduinolSP | Arduine 1.8.19
File JEdit Sketch Tools Help
Mew Ctrl+MN
Open... Ctrl+ 0O £
Open Recent Built-in Examples
{ Sketchbook N
Examples . 02.Digital
Close Ctrl+W 03.Analog
Save S M.Communication
Save As..  CtINShift+S e
06.5ensors
Page Setup  Ctrl+5higsP 07.Display
Print Ctrl+P 08.5trings
Preferences  Ctrl+Comma 0a.use
10.5tarterkit_Basickit
T Ll 11.ArduinolsP |
IT=— 77 U o= ICOE7OFT

ISF using

controlle:

MOSI and !

1

P! ArduinolsP

In this guide the programmer Arduino used is Arduino Uno, so the board selection

should be Arduino Uno.

File Edit Sketch| Tools JHelp

& ArduinolsP | Arduing 1.8.19

ArduinolsP
154 #defing
155 | #defing
$defin:
157 | #defing

I
non
1 oy

Auto Format

Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter

&ViFHm S WIFIMNIMNA Firrmware Updater

void

(=]
R T B & =

#Fifdef

Board: "Arduino Uno"

Port: "COMT (Arduino Uno)"

[+

#inclu

fel=ze

LT L TR T LT T )
3

#defin

Get Board Info

Programmer: "AVRISP mkdl"

Burn Bootloader

Ctrl+T

Ctrl+ Shift+| "
Ctrl+Shift+ P
Ctrl+5Shift+L

[ =t M LI B

SR

For purchase & enquiries, please contact sales@synacorp.com.my or call +604-5860026



SYNACORP TECHNOLOGIES SON. BHD. (1310487-K)

‘ No.25 Lorong 1/883. Bandar Tasek Mutiara.
‘I\ A\C 14120 Simpang Ampat. Penang, Malaysia.
i DRP T:+604.586.0026 F- +604.586.0026

Your Strategic Solutions Provider WEBSITE: www._synacorp.my EMAIL: sales@synacorp.my

3. Once code uploaded to Programmer Arduino, there are 2 options for User to choose
for Wiring both Arduino’s.
a. Wiring thru Digital and Power Pin
i. Programmer = Uno Target = Uno

- XY
XL
|l

PROGRAMMER
TARGET

NI 907¥NY

Example wiring between both Arduino Uno via Digital Pin

ii. Programmer = Uno Target = Nano

n
9 08 D7 Db

o
LU =
S B
= i
<
e =
Gl :
o
(2’
a.

AVLI9IA
p12 D11 D10

(~=WMmd)

Example wiring between Arduino Uno and Nano via Digital Pin
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b. Wiring thru ICSP Header
i. Programmer = Uno Target = Uno

Loutnpuy WXy
B3l
[l
TARGET
outnpJy XY
XL
[l

L

=
Ll
=
=
<
o
9
o
2
a

'

Example wiring between both Arduino Uno via ICSP Pin

ii. Programmer = Uno
Target = Nano

DIGITAL (PWM=~)

Arguilno

PROGRAMMER

ANALOG IN ‘ )

¢ 210

11¢ 210
eoe 0

Example wiring between Arduino Uno and Nano via ICSP Pin
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4. Wiring table & ICSP Pinout

miso 1@ @2 +vce
sck 3|]@ @2 MosI
rRsT 5@ @]s onp

Icsp

Programmer Board
D10 RESET
COPI / MOSI / D11 COPI / MOSI / D11
CIPO / MISO / D12 CIPO / MISO / D12
SCK /D13 SCK / D13

5V 5V
GND GND

G-A). Flashing the MiniCore bootloader

Normally, flashing bootloader is only required when the bootloader is corrupted.

1. Once wiring setup is finished, select the ATmega328 from Arduino IDE by navigate to
toolbar > Tools > Board: “...” > MiniCore > ATmega328.
2. Follow the board setting as image below. Tools > Variant: “328PB” > select 328PB.

Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

@ ArduinolsP |
File Edit Sketc

#defind
#defing
#defing
#defind
iFi101 / WiFiNINA Firmware Updater

Board: "ATmega328"

flock: "External 16 MHz"
BOD: "BOD 2.7V"

EEPROM: "EEPROM retained"
mpiler LTO: "LTO enabled”
328P / 328PA
Bootloader: "Yes (UARTO)" b 328 / 328A
Baud rate: "Default”
Port: "COMT (Arduino Uno)" td
Get Board Info

sel v W v W

1718 SP] Prograrmmer >r, uint® t datg

172 Burn Bootloader
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3. Then, again on the toolbar select Tools > Programmer > Arduino as ISP. Connect
only the programmer Arduino to PC. The target Arduino will get supply power from
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the programmer and both boards should be powered ON.

157  #defing

159 |void pi

@ ArduinolSP | Arduino 1.8.19

Auto Format Cirl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Crl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "ATmega328"

Clock: "External 16 MHz"
BOD: "BOD 2.7V"

EEPROM: "EEPROM retained"
Compiler LTC: "LTO enabled"
Variant: "328PB"

Bootloader: "Yes (UARTO)"
Baud rate: "Default”

Port: "COMT (Arduino Uno)"
Get Board Info

[ Programmer: "Arduino as I5P"

Burn Bootloader

[_VERSICN != 10001 // {

WW W W W W W v w

USBasp
USBasp slow

174 b

uint32 t getClockFreq()

173 (void) dataMode;

USBtinylSP
LISBtinylSP slow

const |

Arduino as ISP

177 return clockFreq;

Bootloader to begin flashing process. Click on Toolbar > Tools > Burn Bootloader.

Kplained Mini
Atmel-ICE ISP

4. Make sure to select correct COM Port (your programmer Arduino), click on Burn

& ArduinclSP | Arduino 1.8.19

File Edit Sketc

ArduinolsP

154 #defind
155 #defing
156 #defind
157 #defing
159 oid py
161 | #ifde

162 |#inclu
163 #else

165 | #defind
167 (#if !df
l16BBl class |
leg publj
170 /i
171 5F]

Auto Format

Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Menitor

Serial Plotter
WiFi101 / WiFiNINA Firmware Updater

Board: "ATmega32d"

Clock: "External 16 MHz"
BOD: "BOD 2.7V"

EEPROM: "EEPROM retained"”
Compiler LTO: "LTO enabled"
Variant: "328PB"

Bootloader: "Yes (UARTD)"
Baud rate: "Default”

Port

Get Board Info

Programmer: "Arduine as [SP"
[ Burn Bootloader

Ctrl+T

Ctrl+Shift+|
Ctrl+Shift+M
Ctrl+Shift+L
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5. The flashing process should take around 3 to 10 seconds to finish. Once finished, the
status bar will show “Done burning bootloader”. Done! Disconnect both Arduino.

o ArduinolSP | Arduino 1.8.19 — O X @ ArduinelSP | Arduino 1.8.1% — O b
File Edit Sketch Tools Help File Edit Sketch Tools Help

/{ BArduinoISP
1 Randall Bohn 2/ yright (c) 2008-2011 Randall Bohn

// If you requi 1se, sSee 3 S e nse, see

// https://openscurce.org/licenses/bsd-license.php 1 S .org/licenses/bsd-license.php
W

only). EEPROM retained. Default. . ] LTO enabled, External 16 MHz on COME

G-B). Flashing the ATmega328PB bootloader

1. Once wiring setup is finished, select the ATmega328 from Arduino IDE by navigate to
toolbar > Tools > Board: “...” > ATmega328PB > ATmega328PB.

@ ArduinolP | Arduina 1.8.19 = O X
File Edit Sketch Tools Help
V14 . Auto Fermat Ctrl+T E
Archive Sketch
ArduinolSF Fix Encoding & Reload =
17 Manage Libraries... Ctrl+Shift+| |
: Serial Monitor Ctrl+Shift+M
. Serial Plotter Ctrl+Shift+L
: LWiFH 01/ WiFiNIMA Firmware Updater
\ Ising
7 [ Board: "ATmega328PB" ] b Boards Manager...
Port: "COM4 (Arduino Uno)" b i rds 3
Get Board Info ATmeqa328PB \blo ATmega328PB |
- Programmer: "AVRISP mkll" b Sl 2
12 Burm Bootloader ESP8266 Boards (3.1.2) »
- MiniCore »
14 MISC °. . 5V {!) Avoid this pi Rasoberry Pi RP2M40(A.04) 5
15/ SCK . . MOSI aspoery H (40.1)
16 |7/ . . GND SparkFun AVR Boards >
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2. Then, again on the toolbar select Tools > Programmer > Arduino as ISP. Connect
only the programmer Arduino to PC. The target Arduino will get supply power from
the programmer and both boards should be powered ON.

@ ArduinolSP | Arduina 1.8.19 = a *x
File Edit Sketch|Tools JHelp
Aute Format Ctrl+T
Archive Sketch
ArduinolSP ix Encoding & Reload
1 // Aray anage Libraries... Ctrl+Shift+] |
EOPT seal Monitor Ctrl+ Shift-M
y ; Serigl Plotter Ctrl+Shift+L
WiFin01 / WiFiNINA Firmware Updater
f Thi{ sing
Board: \ATmega328PB" >
Port: "CPMA" » [olle:
Get Boarggdnfo and
| Programmer: "AVRISP midl" | 3 AVRISP
Burn Bootloader *  AVRISP mkll
i MTS0 v USBtinyISP
1 SCK MOSI ArduinolSP
-° GND ArduinolSP.org
: ff On some Arduinos (Uno,...), pins MOSI, MISC USBasp ‘
Parallel Programmer
|
Arduino as ISP (ATmega32U4) ‘
Arduino Gemma
BusPirate as ISP
Atmel STK500 development board
Atrmel JTAGICES (ISP mode)
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3. Make sure to select correct COM Port (your programmer Arduino), click on Burn
Bootloader to begin flashing process. Click on Toolbar > Tools > Burn Bootloader.
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4. The flashing process should take around 3 to 10 seconds to finish. Once finished, the
status bar will show “Done burning bootloader”. Done! Disconnect both Arduino.
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H). Uploading the code to the board that uses custom bootloader.

Based on which types of bootloaders that user flashed before, to upload the code user must
select that type or it will fail.

MiniCore

1. If MiniCore bootloader was flashed before, select the Board: “...” > MiniCore >
ATmega328” and make sure the Variant is selected correctly as “328PB”.
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2. Make sure to select the 328PB variant from the toolbar, Tools > Variant: “...” >
328PB. Make sure to select the correct COM Port for your Arduino, each PC assigns
the COM port number differently.
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3. Click the Upload button as usual after selecting the board & COM port. Once code
uploaded the Arduino IDE should display Done Uploading. Done! Your Arduino
should run the latest code.
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1. If ATmega328PB bootloader was flashed before, select the Board: “...” >
ATmega328PB > ATmega328PB.
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2. Make sure to select the correct COM Port for your Arduino, each PC assigns the COM
port number differently.
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3. Click the Upload button as usual after selecting the board & COM port. Once code
uploaded the Arduino IDE should display Done Uploading. Done! Your Arduino
should run the latest code.
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